Missing Captivate Quiz Buttons? We Can Fix It

In their most recent update to Captivate 9.0.2, Adobe made many fantastic changes. They sped up the load and publish time for Captivate projects, they amped up the Assets tool and they provided a link to the new Captivate community. However, one change they made caused some buttons on our eLearning Brothers templates to disappear when published or previewed.

The buttons in question are the Captivate quiz buttons within our Captivate templates.

missingbutton001

As you can see, prior to release 9.0.2, all these buttons had a Style Name of [Default Text Button Style], and a style (in the drop-down list) of Text Button. While the new update keeps that style information, the buttons disappear when previewed or published. Even when a new project is begun, if you change the button style to a Text Button, the buttons react the same way.

The other two style options in the drop-down menu are Transparent Button and Image Button. They work just fine and cause no issues. In fact, with the new release, the default is now set to [Default Quiz Button Style] with a style of Transparent Button. Changing that style to Text Button, triggers the same behavior described above.

At first it seemed we only had a couple of options. Option 1 was to instruct our users to go through each and manually change them from [Default Text Button Style] and Text Button to [Default Quiz Button Style] and Transparent Button. But that seemed like a lot of work to impose on our users. Option 2 was to go through each template and change the button styles. But, again, that seemed like a lot of work for something that seemed to be ingrained not in our templates, but in the software itself. So we decided to go with Option 3: Reach out to Adobe for answers.

We received a response with a fix that is quick and easy to apply. And the good news is, they already have this slated to be fixed in the next update.

Here are the steps you need to take to make sure your quiz buttons continue to work the way you’ve grown accustomed to.

NOTE: Make sure you’ve saved your work and closed Captivate before proceeding.

  1. Download a new CPHTMLPublish.dll file by clicking on this link.
  2. Browse to your Captivate installation folder (on Windows machines it’s found at C:\Program Files\Adobe\Adobe Captivate 9 x64)
  3. Rename the current CPHTMLPublish.dll to CPHTMLPublish.bak (or some similar name)
  4. Copy the new one (downloaded in Step 1 above) to replace the one you just renamed.
  5. Launch Captivate and verify that the issue has been fixed by creating a new quiz question and then previewing it.

That’s it! Very simple and quick. Once that’s done, you should be able to work with all our eLearning Brothers Templates with no quiz button issues. So go download to your heart’s content and enjoy the many awesome features of Captivate 9.0.2.

 

Pin It on Pinterest